Project

General

Profile

Bug #23733

Error when changing or refreshing manifest

Added by Stephen Benjamin about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1582221

Description of problem: Whenever I try to update

Version-Release number of selected component (if applicable): 6.4.0 snap 4

How reproducible: Always.

Steps to Reproduce:
1. Upload a manifest
2. Attach some content hosts
3. Attempt to refresh manifest.

Actual results: Error:
```
Error refreshing manifest. Validation failed: Hostgroups expecting hostgroups used by hosts or inherited (check mismatches report)., Domains expecting domains used by hosts or inherited (check mismatches report)., Subnets expecting subnets used by hosts or inherited (check mismatches report)., Compute resources expecting compute resources used by hosts or inherited (check mismatches report)., ApplicationRecord|Capsules expecting capsules used by hosts or inherited (check mismatches report)., Ptables expecting ptables used by hosts or inherited (check mismatches report).
```

Expected results: Refresh success

Additional info:
Talked to jsherril about this and we looked into this. He found when the update is happening the User context is nil.

Associated revisions

Revision f8c98b77 (diff)
Added by Stephen Benjamin about 3 years ago

fixes #23733 - bypass foreman mismatches on manifest refresh

When Foreman organizations become invalid due to mismatches, the
finalize step in manifest refresh will fail due to update_attributes
triggering rails validations.

History

#1 Updated by The Foreman Bot about 3 years ago

  • Assignee set to Stephen Benjamin
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7402 added

#2 Updated by Andrew Kofink about 3 years ago

  • Legacy Backlogs Release (now unused) set to 338
  • Subject changed from Error when changing or refreshing manifest to Error when changing or refreshing manifest

#3 Updated by Stephen Benjamin about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF