Project

General

Profile

Actions

Bug #23815

closed

RHEV api v4 host creation: undefined method `clusters'

Added by Ori Rabin over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - oVirt
Target version:
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1585132

Description of problem:
When creating a host on RHEV using API v4 through CLI, the traceback appears in production.log (attached), error is displayed and the machine is not created. This is somewhat similar to bug 1585092, but:
1) only applies to CLI (read: I don't know how to reproduce using WUI)
2) applies both to image based and network based hosts
3) the machine is not created in the end
This error also happens sooner and if workarounded, bug 1585092 still appears.

Version-Release number of selected component (if applicable):
Sat 6.4 snap 5

How reproducible:
Deterministic

Steps to Reproduce:
  1. hammer host create --architecture x86_64 --compute-profile-id 1 --compute-resource-id 1 --content-source-id 1 --content-view-id 1 --domain-id 2 --environment-id 1 --interface compute_network=a1f9eb04-9b92-4940-b65f-1ba87adf9cb5,mac=00:1a:4a:16:01:a8,ip=192.168.1.111,managed=true,primary=true,provision=true --ip 192.168.1.111 --lifecycle-environment-id 1 --location-id 2 --mac 00:1a:4a:16:01:a8 --name host-hammer-image-based-apiv4 --operatingsystem-id 1 --organization-id 1 --partition-table-id 1 --product-id 13 --root-password toortoor --subnet-id 1 --kickstart-repository-id 2

or image based

  1. hammer host create --architecture x86_64 --compute-profile-id 1 --compute-resource-id 1 --content-source-id 1 --content-view-id 1 --domain-id 2 --environment-id 1 --interface compute_network=a1f9eb04-9b92-4940-b65f-1ba87adf9cb5,mac=00:1a:4a:16:01:a8,ip=192.168.1.111,managed=true,primary=true,provision=true --ip 192.168.1.111 --lifecycle-environment-id 1 --location-id 2 --mac 00:1a:4a:16:01:a8 --name host-hammer-image-based-apiv4 --operatingsystem-id 1 --organization-id 1 --partition-table-id 1 --product-id 13 --provision-method image --root-password toortoor --subnet-id 1 --image-id 2

Actual results:
Could not create the host:
Failed to create a compute rhev3 (RHV) instance host-hammer-image-based-apiv4.example.com: undefined method `clusters' for "5aaaaa41-035d-0157-0166-00000000030b":String

Expected results:
No traceback, no error, host created


Related issues 1 (0 open1 closed)

Related to Foreman - Tracker #19568: Migrate to oVirt APIv4 APIClosed

Actions
Actions #1

Updated by Ori Rabin over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Ori Rabin
Actions #2

Updated by Ori Rabin over 5 years ago

PR opened for this in fog-ovirt: https://github.com/fog/fog-ovirt/pull/26
Keeping the issue here because of the dependency bump that will be needed to get the fix.

Actions #3

Updated by Ori Rabin over 5 years ago

Actions #4

Updated by Ivan Necas over 5 years ago

  • Status changed from Assigned to Closed
  • Target version set to 1.19.0
  • Triaged set to No
  • Pull request https://github.com/theforeman/foreman/pull/5828 added

The dependency was pulled as part of https://github.com/theforeman/foreman/pull/5828

Actions

Also available in: Atom PDF