Project

General

Profile

Bug #23831

Create RHEV host: Listing Images produces traceback when no images on CR

Added by Ori Rabin 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - oVirt
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1582210

Description of problem:
In a Hosts -> Create Host dialogue, when RHEV selected as a provider, listing OS images causes traceback when there are no images added to the Compute Resource.

Version-Release number of selected component (if applicable):
Sat6.4 snap4

How reproducible:
Deterministic

Steps to Reproduce:
0. Have some CR and OS with image with that OS in CR
1. Hosts -> Create Host
2. Select Org etc. as necessary
3. Go to Operating System tab
4. Select arch, OS
5. # foreman-tail
6. Select Image-Based

Actual results:
Traceback in production.log

Expected results:
No traceback

Additional info:
I haven't noticed any other problems caused by this. Traceback attached.

Associated revisions

Revision 05a143bd (diff)
Added by Ori Rabin 4 months ago

Fixes #23831 - Fix JS for oVirt Image based provisioning

History

#1 Updated by Ori Rabin 5 months ago

  • Assignee set to Ori Rabin
  • Status changed from New to Assigned

#2 Updated by The Foreman Bot 5 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5658 added

#3 Updated by Tomer Brisker 4 months ago

  • Triaged set to No
  • Target version set to 1.19.0
  • Fixed in Releases 1.19.0 added

#4 Updated by Anonymous 4 months ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF