Project

General

Profile

Bug #23867

CV Package filters not handling greater than or less than properly

Added by Partha Aji 5 months ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Brad
Fixed in Releases:
Found in Releases:

Description

Given a CV that is using an exclude filter for RPMS. The filter has a rule that is using version range on a package. After changing this rule to "Greater than",
no packages got excluded when publishing the CV.

Steps to Reproduce:
1. Create a CV with "Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server " repo

2. Create an exclude fitler for kernel pacakge like this

Type: Exclude
RPM: kernel
Version "range": between 3.10.0-327.36.3.el7 and 3.10.0-693.36.3.el7

3. update the same filter rule created in 2 to:

Type: Exclude
RPM: kernel
Version "Greater than": 3.10.0-693.36.3.el7

4. publish the CV

Actual results:

Kernel 3.10.0-862.2.3.el7 is included

Expected results:

Kernel 3.10.0-862.2.3.el7 should not be included because it is higher than 3.10.0-693.36.3


Related issues

Is duplicate of Katello - Bug #20876: Editing a content view package filter rule with greater or less than breaks the filterClosed2017-09-07

History

#1 Updated by Partha Aji 5 months ago

  • Target version set to 160

#2 Updated by Partha Aji 5 months ago

  • Bugzilla link set to 1582049

#3 Updated by Partha Aji 5 months ago

  • Is duplicate of Bug #20876: Editing a content view package filter rule with greater or less than breaks the filter added

#4 Updated by Partha Aji 5 months ago

  • Status changed from New to Closed

#5 Updated by Justin Sherrill 5 months ago

  • Legacy Backlogs Release (now unused) set to 166
  • Status changed from Closed to Duplicate

Also available in: Atom PDF