Project

General

Profile

Bug #23905

Default ansible_dir should be ~foreman-proxy

Added by Daniel Lobato Garcia 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
Foreman modules
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Otherwise, ~foreman-proxy/.ansible.cfg settings are ignored when running Ansible jobs.

Associated revisions

Revision 4acf2d6a (diff)
Added by Daniel Lobato Garcia 4 months ago

Fixes #23905 - Use /usr/share/foreman-proxy as ansible_dir

Using /etc/ansible means that the ~foreman-proxy/.ansible.cfg file we
had set up will be ignored. This means the callback is ignored and any
other options we might set in /etc/foreman-proxy/ansible.cfg

History

#1 Updated by Daniel Lobato Garcia 4 months ago

  • Project changed from Foreman to Installer

#2 Updated by Daniel Lobato Garcia 4 months ago

  • Category set to Foreman modules

#3 Updated by Daniel Lobato Garcia 4 months ago

  • Bugzilla link set to 1590362

#4 Updated by Ewoud Kohl van Wijngaarden 4 months ago

IMHO it should be configurable. Ideally we can change it to /etc/foreman-proxy/ansible in production for configs and /var/lib/foreman-proxy/ansible for state. Currently we do this via symlinks in RPMs but that's a bit ugly IMHO.

#5 Updated by The Foreman Bot 4 months ago

  • Assignee set to Daniel Lobato Garcia
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-foreman_proxy/pull/432 added

#6 Updated by Daniel Lobato Garcia 4 months ago

It's configurable already, both in the installer or manually changing /etc/foreman-proxy/settings.d/ansible.yml. The issue is really just about the default value

#7 Updated by Marek Hulán 4 months ago

I think the suggested change is valid and already an improvement to current state. Even though config should not live in /usr, that's how we configure foreman-proxy user home and that is where ansible searches for its config. Opening a refactoring issue for later split would be good, but we'd need to handle upgrade path too. Sounds big for something we'll require for 1.18

#8 Updated by Anonymous 4 months ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#9 Updated by Ewoud Kohl van Wijngaarden 3 months ago

  • Triaged set to No
  • Target version set to 1.18.0
  • Fixed in Releases 1.18.0 added

Also available in: Atom PDF