Project

General

Profile

Bug #23915

Create Host -> RHEV Image: Incorrect CPU cores count filled when using APIv4

Added by Ori Rabin almost 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources - oVirt
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1589779

Description of problem:
In a host creation form, when I select a RHEV CR that uses APIv4 and select some image in the OS tab, I get incorrect number (1) in Cores field in the VM tab. This does not happen with APIv3. I guess this is caused by actually using processor count instead of core count.

Version-Release number of selected component (if applicable):
Sat 6.4 snap 7

How reproducible:
Deterministic

Steps to Reproduce:
1. Have a Sat, RHEV with some template with cpu_count!=cores!=1, this RHEV added to Sat (with apiv4==true) and Image assigned to it, using that template
2. Hosts -> Create Host
3. Select RHEV as provider, go to OS tab, select arch + OS, select Image Based
4. Select the image, go to VM tab

Actual results:
Cores==1

Expected results:
Cores should be number of cores set in the template


Related issues

Is duplicate of Foreman - Bug #23916: Create Host -> RHEV Image: Incorrect CPU cores count filled when using APIv4Closed

History

#1 Updated by Ori Rabin almost 2 years ago

  • Status changed from New to Duplicate

#2 Updated by Ori Rabin almost 2 years ago

  • Is duplicate of Bug #23916: Create Host -> RHEV Image: Incorrect CPU cores count filled when using APIv4 added

Also available in: Atom PDF