Project

General

Profile

Bug #23932

ApplicationJob tests fail when run on jenkins from a plugin

Added by Adam Ruzicka about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Team Backlog:
Fixed in Releases:
Found in Releases:

Related issues

Related to Foreman - Bug #23611: ApplicationJob starts when foreman_tasks does not existClosed2018-05-16

Associated revisions

Revision 30aa03f4 (diff)
Added by Adam Ruzicka about 1 year ago

Fixes #23932 - Fixes failing application job tests for some plugins

The tests were failing with:
Sequel::DatabaseError: PG::DuplicateTable:
ERROR: relation "dynflow_execution_plans" already exists

This failure was probably caused by forcing initialization of the
Dynflow world in a before test block.

History

#1 Updated by Adam Ruzicka about 1 year ago

  • Related to Bug #23611: ApplicationJob starts when foreman_tasks does not exist added

#2 Updated by The Foreman Bot about 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5690 added

#3 Updated by Adam Ruzicka about 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#4 Updated by Ivan Necas about 1 year ago

  • Legacy Backlogs Release (now unused) set to 330

#5 Updated by The Foreman Bot about 1 year ago

  • Pull request https://github.com/theforeman/foreman/pull/5692 added

Also available in: Atom PDF