Project

General

Profile

Bug #23947

Package Information field for Applicable and Installable (WEBUI>Content>Packages>) are not correctly shown

Added by Brad Buckingham almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Repositories
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1588880

Description of problem:

Package Information field for Applicable and Installable (WEBUI> Content> Packages>) is not shown properly. Example:

httpd-2.4.6-80.el7.x86_64

Package Information

Installed On: 0 Host(s)
Applicable To: 0 Host(s) <==== wrong info
Upgradable For: 6 Host(s) <==== wrong info

Version-Release number of selected component (if applicable): 6.3.0

How reproducible: Always

Steps to Reproduce: (example)

1. Check package info on WEBUI> Content> Packages> httpd-2.4.6-80.el7.x86_64
It shows 0 Applicable and 6 Upgradable Hosts

2. On Hosts > Content Hosts > search for:

applicable_rpms=httpd-2.4.6-80.el7.x86_64

Result: It shows correctly 6 Hosts

3. On Hosts > Content Hosts > search for:

upgradable_rpms=httpd-2.4.6-80.el7.x86_64

Actual Result: Package Information displayed on Content > Packages >
for a particular package is showing back to front (which is wrong)

Expected results:

SatWEBUI > Content > Packages >

Package Information field should display correct information.

Additional info:

Another example for a package under Content -> Packages:

Current Package Information:

Installed On 7 Host(s)
Applicable To 43 Host(s) <= clicking on this will show list of 45
Upgradable For 45 Host(s) <= clicking on this will show list of 43

History

#1 Updated by Brad Buckingham almost 4 years ago

  • Difficulty set to easy
  • Assignee set to Brad Buckingham
  • Subject changed from Package Information field for Applicable and Installable (WEBUI>Content>Packages>) are not correctly shown to Package Information field for Applicable and Installable (WEBUI>Content>Packages>) are not correctly shown

#2 Updated by Brad Buckingham almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 166
  • Status changed from New to Duplicate

Dupe of 23172. :)

Also available in: Atom PDF