Project

General

Profile

Bug #23951

Config group is not working with customer user role. (Failing with Stack level too deep)

Added by Marek Hulán 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Search
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1560672

Description of problem:

Created a role and set Resource type = Host and Search = Config Group. Assign this role to the user and login with the user which is using this customized role. Go to Hosts page, it shows error = Stack level too deep.

Version-Release number of selected component (if applicable):

Satellite 6.2.12

How reproducible:
Always

Steps to Reproduce:

1. Create a config group.

2.Add a role with resource type = Content Host, Host, Host Collection, Location and Host with config_group (Refer Image = 6.2.12.Customers_Filter-1.png)

3. and log in with that user and go to Hosts page in the satellite. We will get Stack level too deep error.

Actual results:

Facing issue = Stack level too deep error

Expected results:
User should be able to view the all hosts page in satellite.

Additional info:
We have reproduced same on 6.2.12, 6.2.13 and 6.3.0 and we are getting the same error. While reproducing the issue we added some more resource types just confirm the permission details but we got the same error.

Associated revisions

Revision 89a3e4c2 (diff)
Added by Marek Hulán 5 months ago

Fixes #23951 - fix searching by config group

History

#1 Updated by Marek Hulán 5 months ago

  • Assignee set to Marek Hulán
  • Category set to Search
  • Subject changed from [Satellite 6.2.14] Config group is not working with customer user role. (Failing with Stack level too deep) to Config group is not working with customer user role. (Failing with Stack level too deep)

this was present since config groups were introduced

#2 Updated by The Foreman Bot 5 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5698 added

#3 Updated by Tomer Brisker 5 months ago

  • Legacy Backlogs Release (now unused) set to 353

#4 Updated by Marek Hulán 5 months ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF