Project

General

Profile

Bug #23960

Foreman - "fips_enabled" Puppet Fact is not Parsed Correctly

Added by Barry Gestwicki over 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Facts
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

As we are working towards enabling FIPS on RHEL7 systems in our environment, I opted to try and search for "Facts" > "facts.fips_enabled = false". However, strangely enough, the only value that I can select is "true" for this fact. This behavior is present in all three Foreman environments in our organization, so it's clearly not a fluke. In fact, in the one environment where FIPS has not been enabled on any systems, if I start to query "facts.f", fips_enabled isn't even an available fact to hone in on. In summary, Foreman doesn't appear to be pulling in the fips_enabled fact for any systems where the value is false. For what it's worth, I have confirmed that the various yaml files in /opt/puppetlabs/server/data/puppetserver/yaml/facts do contain "fips_enabled: false" entries for applicable systems. Feel free to let me know if I can provide any additional information, and thanks in advance for your assistance!


Related issues

Is duplicate of Foreman - Bug #25483: Custom boolean facts with false value are not importedClosed

History

#1 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Related to Bug #25483: Custom boolean facts with false value are not imported added

#2 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Related to deleted (Bug #25483: Custom boolean facts with false value are not imported)

#3 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Related to Bug #25483: Custom boolean facts with false value are not imported added

#4 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Related to deleted (Bug #25483: Custom boolean facts with false value are not imported)

#5 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Is duplicate of Bug #25483: Custom boolean facts with false value are not imported added

#6 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Status changed from New to Duplicate

This is a duplicate of #25483 which has been merged and is part of 1.21.0

Also available in: Atom PDF