Project

General

Profile

Bug #23979

hammer fact list: 'organization' not recognized for searching!

Added by Shira Maximov 6 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
API
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1592233

Description of problem:

hammer fact list provides --organization/location options:

  1. hammer fact list --help
    Usage:
    hammer fact list [OPTIONS]

Options:
--location LOCATION_NAME Location name
--location-id LOCATION_ID
--location-title LOCATION_TITLE Location title
--order ORDER Sort results
--organization ORGANIZATION_NAME Organization name
--organization-id ORGANIZATION_ID Organization ID
--organization-title ORGANIZATION_TITLE Organization title
--page PAGE Paginate results
--per-page PER_PAGE Number of entries per request
--search SEARCH Filter results
-h, --help Print help

but actually they cannot be used:

  1. hammer fact list --organization-id 1
    400 Bad Request
    Field 'organization' not recognized for searching!
  2. hammer fact list --location-id 2
    400 Bad Request
    Field 'location' not recognized for searching!

Version-Release number of selected component (if applicable):
6.4 snap 8
satellite-6.4.0-9.beta.el7sat.noarch
tfm-rubygem-hammer_cli-0.13.0-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman-0.13.0-1.el7sat.noarch

How reproducible:
always

Additional info:

previous version does not provide org/location options

satellite-6.3.1-3.el7sat.noarch
tfm-rubygem-hammer_cli-0.11.0.1-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman-0.11.0.5-1.el7sat.noarch
tfm-rubygem-hammer_cli_katello-0.11.3.5-1.el7sat.noarch

  1. hammer fact list --help
    Usage:
    hammer fact list [OPTIONS]

Options:
--order ORDER sort results
--page PAGE paginate results
--per-page PER_PAGE number of entries per request
--search SEARCH filter results
-h, --help print help

Associated revisions

Revision 4eb193da (diff)
Added by Shira Maximov 4 months ago

Fixes #23979 - add option to search location & organization

History

#1 Updated by Shira Maximov 6 months ago

  • Category set to Facts
  • Project changed from Foreman to Hammer CLI

#2 Updated by Tomáš Strachota 6 months ago

This is imho an API issue. Apidoc mentions organization_id in the parameters and hammer correctly uses it. Therefore I'd say it's either wrong apidoc or issue in the controller.

#3 Updated by Shira Maximov 6 months ago

  • Category changed from Facts to API
  • Project changed from Hammer CLI to Foreman

The problem is in the API it is not possible to run :
http://localhost:3000/api/v2/fact_values?location_id=1
in the api

#4 Updated by The Foreman Bot 6 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5740 added

#5 Updated by Shira Maximov 4 months ago

  • Triaged set to No
  • Assignee set to Shira Maximov

#6 Updated by Tomer Brisker 4 months ago

  • Fixed in Releases 1.20.0 added

#7 Updated by Shira Maximov 4 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF