Project

General

Profile

Bug #24020

yum Update from satellite 6.3.1 to 6.4 failed at dependency resolution

Added by Chris Roberts about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Immediate
Assignee:
Category:
Installer
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from BZ:

Description of problem: Yum update on 6.3.1 failed at dependency resolution

--> Finished Dependency Resolution
Error: rh-mongodb34-mongodb-syspaths conflicts with mongodb-2.6.11-2.el7sat.x86_64
Error: rh-mongodb34-mongodb-server-syspaths conflicts with mongodb-server-2.6.11-2.el7sat.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

  1. yum repolist
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
    repo id repo name status
    rhel-7-server-extras-rpms/x86_64 Red Hat Enterprise Linux 7 Server - Extras (RPMs) 838
    rhel-7-server-rpms/x86_64 Red Hat Enterprise Linux 7 Server (RPMs) 20,501
    rhel-server-rhscl-7-rpms/x86_64 Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server 10,023
    sat6 satellite 6 369
    sat6-maintenance Satellite 6 Maintenance 14
  1. yum whatprovides mongodb
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
    mongodb-2.6.11-2.el7sat.x86_64 : High-performance, schema-free document-oriented database
    Repo : @rhel-7-server-satellite-6.2-rpms
  1. yum whatprovides mongodb-server
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
    mongodb-server-2.6.11-2.el7sat.x86_64 : MongoDB server, sharding server and support scripts
    Repo : @rhel-7-server-satellite-6.2-rpms
  1. yum whatprovides rh-mongodb34-mongodb-syspaths
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
    rh-mongodb34-mongodb-syspaths-3.4.9-1.el7.x86_64 : Convenient wrappers for the rh-mongodb34-mongodb package; replaces the mongodb package
    Repo : rhel-server-rhscl-7-rpms

Version-Release number of selected component (if applicable):
Satellite 6.4 snap 8

How reproducible: always

Steps to Reproduce:
1. yum update

Actual results:

Yum update failed

--> Finished Dependency Resolution
Error: rh-mongodb34-mongodb-syspaths conflicts with mongodb-2.6.11-2.el7sat.x86_64
Error: rh-mongodb34-mongodb-server-syspaths conflicts with mongodb-server-2.6.11-2.el7sat.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Expected results: Successful yum update.


Related issues

Copied to Packaging - Bug #24021: yum Update from satellite 6.3.1 to 6.4 failed at dependency resolutionClosed2018-06-20

Associated revisions

Revision 87b00163 (diff)
Added by Chris Roberts about 3 years ago

Fixes #24020 - Update MongoDB remove to install rh-mongodb34-syspaths

History

#1 Updated by Chris Roberts about 3 years ago

  • Copied to Bug #24021: yum Update from satellite 6.3.1 to 6.4 failed at dependency resolution added

#3 Updated by Jonathon Turel about 3 years ago

  • Legacy Backlogs Release (now unused) set to 338
  • Priority changed from High to Immediate

#4 Updated by The Foreman Bot about 3 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/650 added

#5 Updated by Chris Roberts about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#6 Updated by Greg Sutcliffe about 3 years ago

  • Triaged set to No
  • Found in Releases Katello 3.4.5 added

Also available in: Atom PDF