Project

General

Profile

Bug #24131

Inconsistency in editing a host on web UI

Added by Andrew Kofink almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
-
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1585529

Description of problem:

Given a host that is using a different CV/LE than its hostgroup. When editing it, the hostgroups's default CV and LE are loaded. This behaviour is quite confusing as it makes people think that the updating is not successful after clicking on the submit button.

Version-Release number of selected component (if applicable):

Katello 3.4

How reproducible:

Easy

Steps to Reproduce:
1. Create a hostgroup with a CV and LE
2. Create a host with the hostgroup
3. Edit the host with a different CV and LE
4. Check the editing host page again

Actual results:

On the editing host page, it shows the hostgroups's default CV and LE.

Expected results:

It should show the CV and LE that match the db entry.


Related issues

Has duplicate Katello - Bug #24165: Host view doesn't show correct Lifecycle Environment and Content ViewDuplicate2018-07-05
Is duplicate of Katello - Bug #23706: Unable to override hostgroup parameters from All hosts => edit host on WebUIClosed2018-05-25

History

#1 Updated by The Foreman Bot almost 4 years ago

  • Assignee set to Andrew Kofink
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7490 added

#2 Updated by Justin Sherrill almost 4 years ago

  • Has duplicate Bug #24165: Host view doesn't show correct Lifecycle Environment and Content View added

#3 Updated by Andrew Kofink almost 4 years ago

  • Is duplicate of Bug #23706: Unable to override hostgroup parameters from All hosts => edit host on WebUI added

#4 Updated by Anonymous almost 4 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF