Project

General

Profile

Bug #24140

Navigating back to Subscriptions from Add Subscriptions results in blank page.

Added by Tomáš Strachota about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1597079

Description of problem:
When user clicks the "Add Subscriptions button on the Subs page, and then navigates back via the browser, s/he is welcomed with a blank page.

Version-Release number of selected component (if applicable):
Test in Chrome latest

6.4.0 Snap 10

How reproducible:

Steps to Reproduce:
1. Login and upload a manifest to an org; let it process.
2. Navigate to 'Subscriptions'. Assure this page is populated.
3. Click the 'Add Subscriptions' button.
4. Hit the back button on the browser.

Actual results:
Blank page

Expected results:
User is returned to a populated Subscriptions page.

Additional info:
It's worth checking also the repositories page. I think it's affected too.

Associated revisions

Revision bfd20b92 (diff)
Added by Amir Fefer about 3 years ago

Fixes #24140, #24142 - mount react root from the layout

History

#1 Updated by Tomáš Strachota about 3 years ago

  • Target version set to 219
  • Description updated (diff)

#2 Updated by Greg Sutcliffe about 3 years ago

  • Triaged set to No
  • Team Backlog UX added

#3 Updated by Walden Raines about 3 years ago

  • Target version changed from 219 to Katello 3.7.0

#4 Updated by Amir Fefer about 3 years ago

  • Assignee set to Amir Fefer

#5 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7518 added

#6 Updated by Amir Fefer about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF