Project

General

Profile

Bug #24214

No applicable errata/updates on content host

Added by Christine Fouant about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Urgent
Category:
Errata Management
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1596049

Description of problem: We registered content host to satellite 6.4 snap 9, but not able to see errata/updates for content host in satellite.

Version-Release number of selected component (if applicable): Satellite 6.4 snap 9
  1. rpm -q satellite
    satellite-6.4.0-9.beta.el7sat.noarch

How reproducible: always

Steps to Reproduce:
1. Created activation key with rhel7 server synced
2. Registered rhel 74/75 content host
#rpm -Uvh http://satellite/pub/katello-ca-consumer-latest.noarch.rpm
#subscription-manager register --org="Default_Organization" --activationkey="ak-rhel-7"
#yum -y install katello-agent
3. Navigate Host -> Content host

Actual results:

No applicable errata seen on content host. No errors in production.log and Package Profile Update task completed successfully.

Also note that content host has updates. Updates can pull from satellite using #yum update.

Expected results: Errata/updates on content host should display in satellite.

Additional info:

Associated revisions

Revision 1ffbd8af (diff)
Added by Chris Duryee about 3 years ago

Fixes #24214 - fill in vars on repo URLs

Previously, repo baseurls were sent as-is from redhat.repo to
Satellite. This resulted in the client reporting it was subscribed to
repos that don't exist, since the URLs would have the literal string
`$releasever/$basearch` in it.

This commit adds dnf and yum code to populate `$releasever` and
`$basearch`. It will attempt to use DNF libraries first, and if that
raises an `ImportError`, it will try yum.

History

#1 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-host-tools/pull/66 added

#2 Updated by Justin Sherrill about 3 years ago

  • Target version set to Katello 3.7.0
  • Priority changed from High to Urgent

#3 Updated by Chris Duryee about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF