Project

General

Profile

Bug #24320

Unable to provision on Vmware, no storage data submitted

Added by Marek Hulán 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - VMware
Target version:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1602289

Description of problem:

Version-Release number of selected component (if applicable):
Build: Satellite 6.4.0 snap12

How reproducible:
Always

Steps to Reproduce:
1. On Satellite 6.4.0 snap12
2. Try to Provision a host on Vmware compute resource
3.

Actual results:
Unable to save
Failed to create a compute vmware (VMware) instance trudy-speake.<domain>: undefined method `volumes' for nil:NilClass

Expected results:
Host should be provisioned

Additional info:
PFA, production log and proxy log
Same error trying with and without compute profile

Looking at the log, Storage parameters are never submitted to the controller

Processing by HostsController#create as */*
2018-07-18T03:05:18 [I|app|05082] Parameters: {"utf8"=>"✓", "authenticity_token"=>"L9fjRzKRovzbPck3bQ/jq/rKtcWDeBHLOmz+unDGGpH2oJncUSlo/iRcByGE8Pt7H1GRycLH5dwI7Dbul5hLdg==", "host"=>{"name"=>"trudy-speake", "organization_id"=>"1", "location_id"=>"2", "hostgroup_id"=>"2", "compute_resource_id"=>"3", "compute_profile_id"=>"2", "content_facet_attributes"=>{"lifecycle_environment_id"=>"2", "content_view_id"=>"2", "content_source_id"=>"1", "kickstart_repository_id"=>"18"}, "environment_id"=>"3", "openscap_proxy_id"=>"1", "ansible_role_ids"=>[""], "puppetclass_ids"=>["", "6"], "managed"=>"true", "progress_report_id"=>"[FILTERED]", "type"=>"Host::Managed", "interfaces_attributes"=>{"0"=>{"_destroy"=>"0", "type"=>"Nic::Managed", "mac"=>"", "identifier"=>"", "name"=>"trudy-speake", "domain_id"=>"1", "subnet_id"=>"2", "ip"=>"10.XXXXX", "ip6"=>"", "managed"=>"1", "primary"=>"1", "provision"=>"1", "execution"=>"1", "virtual"=>"0", "tag"=>"", "attached_to"=>"", "compute_attributes"=>{"type"=>"VirtualVmxnet3", "network"=>"network-148"}}}, "compute_attributes"=>{"cpus"=>"1", "corespersocket"=>"1", "memory_mb"=>"4048", "firmware"=>"bios", "cluster"=>"Satellite_Engineering", "resource_pool"=>"Resources", "path"=>"/Datacenters/RH_Engineering/vm/QE", "guest_id"=>"rhel7_64Guest", "hardware_version"=>"Default", "memoryHotAddEnabled"=>"0", "cpuHotAddEnabled"=>"0", "add_cdrom"=>"0", "start"=>"1", "annotation"=>""}, "architecture_id"=>"1", "operatingsystem_id"=>"2", "provision_method"=>"build", "build"=>"1", "medium_id"=>"", "ptable_id"=>"94", "pxe_loader"=>"PXELinux BIOS", "disk"=>"", "root_pass"=>"[FILTERED]", "host_parameters_attributes"=>{"1531897512910"=>{"name"=>"", "value"=>"[FILTERED]", "hidden_value"=>"[FILTERED]", "_destroy"=>"1"}}, "is_owned_by"=>"4-Users", "enabled"=>"1", "model_id"=>"", "comment"=>"", "overwrite"=>"false"}, "media_selector"=>"synced_content"}


Related issues

Related to Foreman - Bug #23290: React + Turbolinks integration break when submitting formsClosed
Related to Foreman - Bug #24345: Breadcrumbs isn't refreshed properly after visiting host edit formNew

Associated revisions

Revision e1e37f14 (diff)
Added by Marek Hulán 2 months ago

Fixes #24320 - stop dropping vmware fields

Revert "Fixes #23290 - Unmount components before dom-update"

This reverts commit b976723b58ad34ef9af77816541b42efc76c1b2a.

History

#1 Updated by Marek Hulán 2 months ago

  • Target version set to 1.18.1
  • Subject changed from Unable to provision on Vmware, no storage data submitted to Unable to provision on Vmware, no storage data submitted

this has been caused by #23290 that unmounts react component before the host form submit

#2 Updated by Marek Hulán 2 months ago

  • Related to Bug #23290: React + Turbolinks integration break when submitting forms added

#3 Updated by The Foreman Bot 2 months ago

  • Assignee set to Marek Hulán
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5864 added

#4 Updated by Marek Hulán 2 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Marek Hulán about 2 months ago

  • Related to Bug #24345: Breadcrumbs isn't refreshed properly after visiting host edit form added

#6 Updated by The Foreman Bot about 2 months ago

  • Pull request https://github.com/theforeman/foreman/pull/5871 added

#7 Updated by Tomer Brisker about 2 months ago

  • Fixed in Releases 1.18.1, 1.19.0, 1.20.0 added

Also available in: Atom PDF