Project

General

Profile

Bug #24339

RFE: Need to set proper filename in Subscription Export CSV response

Added by Partha Aji almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

When a user downloads a CSV of an org's subscriptions, the filename is in the format of "subscriptions-YYYY-MM-DD.csv".

If user is downloading CSVs for multiple orgs, that can get confusing.

How reproducible:

Steps to Reproduce:
1. Create multiple orgs and upload manifests for each.
2. Go to subscriptions page for org 1; click the "Export CSV" button.
3. Repeat step #2 for as many orgs as you have created and uploaded manifests.

Actual results:
The filename is the same for each org (although your browser probably tweaks the filename since it thinks you are re-downloading something).

Expected results:

Default_Org-subscriptions-YYYY-MM-DD.csv
Org_1-subscriptions-YYYY-MM-DD.csv

....etc.


Related issues

Blocked by Foreman - Bug #24338: RFE: Need ability to set filename in CSV responseClosed

Associated revisions

Revision b9505e4e (diff)
Added by Partha Aji almost 2 years ago

Fixes #24339 - Added Org Label for Subs CSV

As a part of Content-> Subscriptions -> Export CSV
this commit prefixes the Org label to the subscriptions csv file.

History

#1 Updated by Partha Aji almost 2 years ago

  • Bugzilla link set to 1597089

#2 Updated by Partha Aji almost 2 years ago

  • Related to Bug #24338: RFE: Need ability to set filename in CSV response added

#3 Updated by Partha Aji almost 2 years ago

  • Related to deleted (Bug #24338: RFE: Need ability to set filename in CSV response)

#4 Updated by Partha Aji almost 2 years ago

  • Blocked by Bug #24338: RFE: Need ability to set filename in CSV response added

#5 Updated by The Foreman Bot almost 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7558 added

#6 Updated by Andrew Kofink almost 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.9.0

#7 Updated by Partha Aji almost 2 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF