Project

General

Profile

Bug #24340

Activation Key cannot be saved in host group

Added by Alexandru Asofie almost 4 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Activation Key
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hi team,

Running foreman 1.17.1-1 with katello 3.6.0-3 on Centos 7.5 I discovered the following issue:
It's is not possible to save an activation key to a host group.

Steps to reproduce:
1. Create an activation key and add a subscription to it (in my case I am using the Red Hat Developer Suite)
2. Create a host group and define an OS which is supported by the subscription attached to the activation key aost ground associate the activation key to the host group. (At this step no error is thrown and it says that the host group was saved successfully)
3. Check the host group settings and the activation key is not present. ]
Also I tried to skip adding the activation key and set it up directly in the host group params as kt_activation_keys but also this parameter doesn't get saved. Any other parameter defined in the host group is saved correctly.

Let me know if you need any logs.

Thanks.
Alex.

Create-Host.png View Create-Host.png 19.3 KB Partha Aji, 07/30/2020 02:20 PM
Create host

History

#1 Updated by Kavita Gaikwad almost 2 years ago

  • Project changed from Foreman Maintain to Katello

Issue seems to be related to Katello so moving under Katello plugin.

#2 Updated by Jonathon Turel almost 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.0.0
  • Category set to Activation Key

#3 Updated by Partha Aji almost 2 years ago

I was unable to reproduce this. I was able to go to the Activation Keys tab in the Hostgroup and see the saved Activation Key. Moreover while I don't see 'kt_activation_keys' in the created Hostgroup, when I apply the hostgroup to a host on the New hosts page I see it as part of the parameters (See attached.)

#4 Updated by Partha Aji almost 2 years ago

  • Target version changed from Katello 4.0.0 to Katello Recycle Bin

Try updating to the latest katello stable and let us know if this is an issue anymore.

#5 Updated by Jonathon Turel almost 2 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF