Project

General

Profile

Bug #24354

Black background instead of transparency on subscription related modals

Added by Walden Raines over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1599875

Description of problem:

See screenshot. Instead of a transparent backdrop on the subscription page modals there is a black background.

Version-Release number of selected component (if applicable): 6.4

How reproducible: Always

Steps to Reproduce:
1. Go to subscriptions page
2. Open the manage manifest modal
3. Note black background instead of transparent

Actual results:

Black backdrop

Expected results:

Slightly transparent backdrop

Additional info:

Note that this happens also on the progress bar modal in the subscriptions table itself.

It looks like this is caused by the modal dialog missing the .in class. For some reason that class is not being applied by patternfly-react when the modal is opened.


Related issues

Related to Foreman - Bug #23486: There are js warnings when a modal (react) opensClosed

Associated revisions

Revision 4fa6778b (diff)
Added by Walden Raines over 1 year ago

Fixes #24354: update react-bootstrap to 0.32.1

Need to update react-bootstrap to 0.32.1 to fix the black modal
background.

https://projects.theforeman.org/issues/24354

History

#1 Updated by Walden Raines over 1 year ago

This is caused by using a react-bootstrap of less than 0.32.1, so need to update the package.json in both katello and foreman to reflect this.

#2 Updated by Walden Raines over 1 year ago

  • Target version set to 1.18.1
  • Category deleted (Subscriptions)
  • Project changed from Katello to Foreman
  • Found in Releases 1.18.0, 1.18.0-RC1, 1.18.0-RC2, 1.18.0-RC3 added

Moving this to foreman since we'll need to update the patternfly-react dependency there.

#3 Updated by Walden Raines over 1 year ago

Actually never mind, https://projects.theforeman.org/issues/23486 takes care of this on the foreman side.

#4 Updated by Walden Raines over 1 year ago

  • Target version deleted (1.18.1)
  • Category set to Subscriptions
  • Project changed from Foreman to Katello

#5 Updated by Walden Raines over 1 year ago

  • Fixed in Releases Katello 3.7.0, Katello 3.7.1 added

#6 Updated by Walden Raines over 1 year ago

  • Found in Releases Katello 3.8.0, Katello 3.7.0, Katello 3.7.1 added
  • Found in Releases deleted (1.18.0, 1.18.0-RC1, 1.18.0-RC2, 1.18.0-RC3)
  • Fixed in Releases deleted (Katello 3.7.0, Katello 3.7.1)

#7 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7559 added

#8 Updated by Walden Raines over 1 year ago

  • Related to Bug #23486: There are js warnings when a modal (react) opens added

#9 Updated by Walden Raines over 1 year ago

  • Target version set to Katello 3.7.0

#10 Updated by Anonymous over 1 year ago

  • Status changed from Ready For Testing to Closed

#11 Updated by Walden Raines over 1 year ago

  • Target version changed from Katello 3.7.0 to Katello 3.7.1

#12 Updated by Andrew Kofink over 1 year ago

  • Triaged changed from No to Yes

Also available in: Atom PDF