Project

General

Profile

Actions

Bug #24355

closed

All parameters for class overridden by default

Added by Ori Rabin almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Parameters
Target version:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1603209

Description of problem:
I imported the puppetlabs-ntp and puppetlabs-stdlib classes. On first run, all was fine. Then, I wanted to change the 'server' parameter, so I opened the smart parameters tab of the ntp class, and found all classes were marked 'overriden'.

I only set the 'server' parameter, but Puppet barfed that all parameters were now filled with empty strings, and thus didn't match the expected types:

From the log on the satellite (which was also the puppet client in my case):
[...]
puppetlabs/puppetserver/puppetserver.log: parameter 'enable_mode7' expects a Boolean value, got String
puppetlabs/puppetserver/puppetserver.log: parameter 'iburst_enable' expects a Boolean value, got String
puppetlabs/puppetserver/puppetserver.log: parameter 'keys_enable' expects a Boolean value, got String
[...]

YAML output on the Satellite:
[...]classes:
ntp:
authprov: ''
broadcastclient: ''
config: ''
config_dir: ''
config_epp: ''
config_file_mode: ''
config_template: ''
disable_auth: ''
disable_dhclient: ''
disable_kernel: ''
disable_monitor: ''
driftfile: ''
enable_mode7: ''
[...]

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. import puppetlabs-ntp in new satellite
2. run puppet
3. go to smart parameters tab for ntp class

Actual results:
all parameters are marked as overriden

Expected results:
None should be

Additional info:

Module I imported: https://forge.puppet.com/puppetlabs/ntp

It happens only with that module, but I do not know whether that is because it was the first one I used (and that was also the case for the person in that thread mentioned above), or because it's really only that module that triggers it.


Related issues 3 (2 open1 closed)

Related to Foreman - Bug #22144: empty smart class parametersNew01/04/2018Actions
Related to Foreman - Bug #18564: Class parameters using module data defaults should not have override enabled on importNew02/20/2017Actions
Related to OpenSCAP - Bug #24719: Overrides for policies, port and host params are not createdClosedOndřej PražákActions
Actions #1

Updated by Ori Rabin almost 6 years ago

  • Subject changed from All parameters for class overridden by default to All parameters for class overridden by default
  • Category changed from PuppetCA to Parameters
  • Status changed from New to Assigned
  • Assignee set to Ori Rabin
Actions #2

Updated by Fabien Combernous almost 6 years ago

  • Found in Releases 1.17.1 added

I upgraded from foreman 1.16.1 to 1.17, on ubuntu 16.04. And immediately after the foreman update i was also concerned by this issue.

Were using puppet module puppetlabs-ntp release 6.2.0. And only the following parameters where overridden : pool, noselect_servers, statistics, statsdir, step_tickers_file.

Some modules i written were also concerned.

My workaround was to uncheck the "override" box for all concerned parameters.

Actions #3

Updated by Fabien Combernous almost 6 years ago

After upgrade from 1.17.1 to 1.18.0 all parameters were well handled , no override issue saw again.

Actions #4

Updated by Ori Rabin almost 6 years ago

  • Related to Bug #22144: empty smart class parameters added
Actions #5

Updated by Ori Rabin almost 6 years ago

  • Related to Bug #18564: Class parameters using module data defaults should not have override enabled on import added
Actions #6

Updated by Tomer Brisker almost 6 years ago

  • Target version set to 1.17.2
Actions #7

Updated by The Foreman Bot almost 6 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5885 added
Actions #8

Updated by Ori Rabin almost 6 years ago

  • Status changed from Ready For Testing to Closed
Actions #9

Updated by Tomer Brisker almost 6 years ago

  • Fixed in Releases 1.20.0 added
Actions #10

Updated by The Foreman Bot almost 6 years ago

  • Pull request https://github.com/theforeman/foreman/pull/5894 added
Actions #11

Updated by The Foreman Bot almost 6 years ago

  • Pull request https://github.com/theforeman/foreman/pull/5895 added
Actions #12

Updated by The Foreman Bot almost 6 years ago

  • Pull request https://github.com/theforeman/foreman/pull/5896 added
Actions #13

Updated by Tomer Brisker almost 6 years ago

  • Fixed in Releases 1.17.2, 1.18.1, 1.19.0 added
Actions #14

Updated by Ondřej Pražák almost 6 years ago

  • Related to Bug #24719: Overrides for policies, port and host params are not created added
Actions

Also available in: Atom PDF