Project

General

Profile

Bug #24372

most of the puppet nodes are out of sync in dashboard

Added by Fabien Combernous over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Since i upgraded from 1.17.1 to 1.18.0, in the dashboard, most of nodes (about 80%) are reported as out of sync. But they are not.

In the dashboard when i follow the link "out of sync hosts", i arrive on a page with the following search string [1]

I understand this request as "show me all nodes with reports made during last 5 minutes", it looks a wrong request.

But worst, when i use the query [2] the result is not the expected one. The two request [1] and [2] are with similar results.

[1] last_report < "5 minutes ago" and status.enabled = true
[2] last_report > "35 minutes ago" and status.enabled = true


Related issues

Is duplicate of Foreman - Bug #24350: Default out of sync interval is 5 minutesClosed

History

#1 Updated by Tomer Brisker over 1 year ago

  • Status changed from New to Duplicate

This is a duplicate of #24350

#2 Updated by Tomer Brisker over 1 year ago

  • Is duplicate of Bug #24350: Default out of sync interval is 5 minutes added

#3 Updated by Ewoud Kohl van Wijngaarden over 1 year ago

Note you can change this yourself by changing outofsync_interval to 35 (instead of the default 5) and puppet_interval to 35 (from the default 30) in settings.

#4 Updated by Ewoud Kohl van Wijngaarden over 1 year ago

  • Project changed from Foreman Maintain to Foreman

Also available in: Atom PDF