Project

General

Profile

Bug #24373

No breadcrumb for Lifecycle Environments

Added by Andrew Kofink almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

The Lifecycle Environment pages don't have breadcrumbs (see screenshot).

Reproduce:
Navigate to a Lifecycle Environment

Actual:
No breadcrumb

Expected:
A breadcrumb allows users to return to the index page, or switch to a different LE show page directly, like all other breadcrumbs in Katello.

Screenshot from 2018-07-24 09-39-17.png View Screenshot from 2018-07-24 09-39-17.png 80.5 KB Actual behavior Andrew Kofink, 07/24/2018 01:39 PM
Screenshot%20from%202018 07 24%2009 39 17

History

#1 Updated by Andrew Kofink almost 4 years ago

  • Bugzilla link set to 1607889

#2 Updated by Thomas McKay almost 4 years ago

A partial fix is already in code via https://projects.theforeman.org/issues/23390

In order for the data to populate breadcrumbs to be present, the index page must be visited. Going directly to a specific environment (try reloading the page once on an env) and the breadcrumb switcher will not work.

Suggest that this issue be closed or put off until the page is moved to react. There is an outstanding suggestion that the environment index page be redesigned.

#3 Updated by Andrew Kofink almost 4 years ago

  • Priority changed from Normal to Low

This issue will most likely be backlogged anyway, since it's not a high priority issue. It'll most likely get fixed with the conversion of this page to React, as you said.

#4 Updated by Andrew Kofink almost 4 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello Recycle Bin
  • Status changed from New to Closed

This seems to be fixed.

Also available in: Atom PDF