Project

General

Profile

Bug #24541

Can not store "Add cdrom drive" on compute profile

Added by Dirk Götz 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

On the Compute Profile using Compute Resource VMware I can select "Add cdrom drive" but when storing the Profile it is not saved, so opening the Compute Profile again the box is unchecked and also using it while creating a Host requires always to check the box again. Using boot disk based provisioning it requires to remember always to check this box or if you forget to delete and recreate the host.

Installation is Foreman 1.18.0, Compute Resource VMware, Bootdisk and Column View Plugin.

Associated revisions

Revision 1ca921c8 (diff)
Added by Marek Hulán 4 months ago

Fixes #24541 - properly display cdrom check

History

#1 Updated by Marek Hulán 5 months ago

  • Bugzilla link set to 1566543

#2 Updated by The Foreman Bot 4 months ago

  • Assignee set to Marek Hulán
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5924 added

#3 Updated by Marek Hulán 4 months ago

The issue is interestingly not in the fact we wouldn't save the add_cdrom value. It's cause by the fact the checkbox is named add_cdrom, which we then turn into "cdrom" in fog attributes. When we redraw the compute profile form, it does not detect add_cdrom is set to 1, therefore it remains unchecked. The same applies when we enter new host form, after choosing compute profile, the checkbox simply remains unchecked.

Dirk, it would be great if you could test the PR and let us know if it fixes the issue for you.

#4 Updated by Dirk Götz 4 months ago

I tested it and it works fine.

Thanks, Marek.

#5 Updated by Tomer Brisker 4 months ago

  • Fixed in Releases 1.20.0 added

#6 Updated by Marek Hulán 4 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF