Project

General

Profile

Bug #24545

Compute resource test connection enables password field

Added by Marek Hulán 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

The fix from #13497 made the password always enabled, so that it does not get disabled after pw change followed by test connection trigger. This does not work in scenario, where user edits existing CR and hits test connection button. It keeps pw field enabled so if I click submit immediately, it fails since the password is empty. User either needs to specify the password again or click the disable button. While testing this I also realized that after testing connection for new CR, the enable/disable button is also displayed.

Regression caused in 1.18 but given the workaround, most likely not worth cherry-picking.


Related issues

Related to Foreman - Bug #13497: InvalidLogin: Cannot complete login due to an incorrect user" when trying to provision a new hostClosed2016-02-01

Associated revisions

Revision 47abbc3d (diff)
Added by Marek Hulán 4 months ago

Fixes #24545 - keep the pw field as it was

History

#1 Updated by Marek Hulán 4 months ago

  • Bugzilla link set to 1389810

#2 Updated by Marek Hulán 4 months ago

  • Related to Bug #13497: InvalidLogin: Cannot complete login due to an incorrect user" when trying to provision a new host added

#3 Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5922 added

#4 Updated by Tomer Brisker 4 months ago

  • Fixed in Releases 1.20.0 added

#5 Updated by Marek Hulán 4 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF