Project

General

Profile

Bug #24632

installer does not work for custom ssl certificates, fails with "illegal option -- r" for katello-certs-check command

Added by Ashish Humbe 11 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

installer does not work for custom ssl certificates, fails with "illegal option -- r" for katello-certs-check command

# satellite-installer --scenario satellite --certs-server-cert /root/satellite.example.com.cert.pem --certs-server-key /root/satellite.example.com.key.pem --certs-server-ca-cert /root/ca-chain.cert.pem --certs-update-server --certs-update-server-ca  
Resetting puppet server version param...
Marking certificate /root/ssl-build/satellite.example.com/satellite.example.com-apache for update
Marking certificate /root/ssl-build/satellite.example.com/satellite.example.com-foreman-proxy for update
Marking certificate /root/ssl-build/katello-server-ca for update
Command '/usr/sbin/katello-certs-check -c "/root/satellite.example.com.cert.pem" -r "/root/satellite.example.com.csr.pem" -k "/root/satellite.example.com.key.pem" -b "/root/ca-chain.cert.pem"' exited with 1:
 /usr/sbin/katello-certs-check: illegal option -- r
Verifies, that custom ssl cert files are usable
as part of the Katello installation.

usage: /usr/sbin/katello-certs-check -c CERT_FILE -k KEY_FILE -b CA_BUNDLE_FILE

Associated revisions

Revision aa5c8f6d (diff)
Added by Ashish Humbe 11 months ago

Fixes #24632 - cert-req needs to be removed

History

#1 Updated by Ewoud Kohl van Wijngaarden 11 months ago

  • Category set to Installer
  • Description updated (diff)
  • Project changed from Installer to Katello

#2 Updated by Ewoud Kohl van Wijngaarden 11 months ago

Looks like commit:35722703f8252ab835b6f5bfd8be04ce4d547465 introduced a regression here.

#3 Updated by The Foreman Bot 11 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/671 added

#4 Updated by The Foreman Bot 11 months ago

  • Pull request https://github.com/Katello/katello-installer/pull/672 added

#5 Updated by The Foreman Bot 11 months ago

  • Pull request https://github.com/Katello/katello-installer/pull/673 added

#6 Updated by Ivan Necas 11 months ago

  • Status changed from Ready For Testing to Closed

#7 Updated by Andrew Kofink 11 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.9.0
  • Pull request deleted (https://github.com/Katello/katello-installer/pull/672)

Also available in: Atom PDF