Project

General

Profile

Bug #24670

Possible regression of #11106 and #21445: Could not find virtual machine network interface matching X

Added by Anthony Somerset about 1 month ago. Updated 30 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

i upgraded to 1.19 RC in order to get native Ubuntu 18.04 support

since that upgrade Vmware create operations (new host or clone existing) have been failing with errors like:

Could not find virtual machine network interface matching ens192

or

Could not find virtual machine network interface matching x.x.x.x

enabled debug logging and here is the relevant section of the log where failure occurs (indentifable info has been sanitized)

2018-08-21T14:12:58 [D|app|8843e] Processing task 'Query instance details for prod-ocs-diam-a.example.com' from 'Host::Managed Main'
2018-08-21T14:12:58 [D|app|8843e] Orchestration::Compute: Trying to match network interfaces from fog   <Fog::Compute::Vsphere::Interfaces
 |     server_id="5002c6e4-a608-c268-6269-617b4f28ac30" 
 |     [
 |                   <Fog::Compute::Vsphere::Interface
 |         mac="00:50:56:82:ee:c9",
 |         network="dvportgroup-707",
 |         name="Network adapter 1",
 |         status="untried",
 |         connected=false,
 |         summary="DVSwitch: 50 02 4a ee 11 19 09 f4-b9 69 08 e3 b9 44 6c 29",
 |         type=RbVmomi::VIM::VirtualVmxnet3,
 |         key=4000,
 |         virtualswitch=nil,
 |         server_id="5002c6e4-a608-c268-6269-617b4f28ac30" 
 |       >,
 |                   <Fog::Compute::Vsphere::Interface
 |         mac="00:50:56:82:4b:99",
 |         network="dvportgroup-405",
 |         name="Network adapter 2",
 |         status="untried",
 |         connected=false,
 |         summary="DVSwitch: 50 02 4a ee 11 19 09 f4-b9 69 08 e3 b9 44 6c 29",
 |         type=RbVmomi::VIM::VirtualVmxnet3,
 |         key=4001,
 |         virtualswitch=nil,
 |         server_id="5002c6e4-a608-c268-6269-617b4f28ac30" 
 |       >
 |     ]
 |   >
2018-08-21T14:12:58 [W|app|8843e] Orchestration::Compute: Could not match network interface #<Nic::Managed id: nil, mac: nil, ip: "x.x.x.x", type: "Nic::Managed", name: "prod-ocs-diam-a.example.com", host_id: nil, subnet_id: 10, domain_id: 6, attrs: {}, created_at: nil, updated_at: nil, provider: nil, username: nil, password: nil, virtual: false, link: true, identifier: "ens192", tag: "", attached_to: "", managed: true, mode: "balance-rr", attached_devices: "", bond_options: "", primary: true, provision: true, compute_attributes: {"type"=>"VirtualVmxnet3", "network"=>"dvportgroup-707"}, ip6: "", subnet6_id: nil>
2018-08-21T14:12:58 [W|app|8843e] Could not find virtual machine network interface matching ens192
2018-08-21T14:12:58 [W|app|8843e] Rolling back due to a problem: [#<Orchestration::Task:0x000055febf6cd540 @name="Query instance details for prod-ocs-diam-a.example.com", @id="Query instance details for prod-ocs-diam-a.example.com", @status="failed", @priority=4, @action=[#<Host::Managed id: nil, name: "prod-ocs-diam-a.example.com", last_compile: nil, last_report: nil, updated_at: nil, created_at: nil, root_pass: "XXXX", architecture_id: 1, operatingsystem_id: 3, environment_id: 1, ptable_id: 92, medium_id: 7, build: true, comment: "", disk: "", installed_at: nil, model_id: nil, hostgroup_id: 4, owner_id: 4, owner_type: "User", enabled: true, puppet_ca_proxy_id: 1, managed: true, use_image: nil, image_file: nil, uuid: "5002c6e4-a608-c268-6269-617b4f28ac30", compute_resource_id: 3, puppet_proxy_id: 1, certname: nil, image_id: nil, organization_id: nil, location_id: nil, type: "Host::Managed", otp: nil, realm_id: nil, compute_profile_id: 4, provision_method: "build", grub_pass: "XXXXXX", global_status: 0, lookup_value_matcher: "fqdn=prod-ocs-diam-a.example.com", pxe_loader: "PXELinux BIOS", initiated_at: nil, build_errors: nil>, :setComputeDetails], @created=1534853560.2990792, @timestamp=2018-08-21 12:12:58 UTC>]
2018-08-21T14:12:58 [I|app|8843e] Removing Compute instance for prod-ocs-diam-a.example.com

Related issues

Is duplicate of Foreman - Bug #24571: With fog-vsphere 2.3 trying to provision to a port group within a distributed switch failsClosed

History

#1 Updated by Anthony Somerset about 1 month ago

Apologies this might be the same bug as #24571 - i didn't find it in searching initially

#2 Updated by Anthony Somerset 30 days ago

  • Bugzilla link set to 24571
  • Status changed from New to Duplicate
  • Fixed in Releases 1.19.0 added

Confirmed fixed in latest RC3

#3 Updated by Anthony Somerset 30 days ago

  • Bugzilla link deleted (24571)

#4 Updated by Anthony Somerset 30 days ago

  • Is duplicate of Bug #24571: With fog-vsphere 2.3 trying to provision to a port group within a distributed switch fails added

Also available in: Atom PDF