Project

General

Profile

Bug #24746

'Associate VM' works but 'Associate VMs' does not

Added by Ori Rabin 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - oVirt
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1620094

Description of problem:
It is possible to associate certain VM from a CR by going to VMS, opening VM details and clicking 'Associate VM'. However, clicking 'Associate VMs' on a VM list doesn't associate anything and says 'No VMs matched any host.' even when there is a matching Foreman host.

Version-Release number of selected component (if applicable):
Tested with Sat 6.4 snap 18 with RHEV CR.

How reproducible:
Deterministic

Steps to Reproduce:
1. Have a VM on CR
2. Create a Host in Foreman with MAC == VM_mac
3. Infrastructure -> Compute Resources -> <CR> -> Virtual Machines -> Associate VMs
4. "No VMs matched any host." green pop-up
5. Open the VM and click 'Associate VM', it gets associated

Actual results:
VM only gets associated when attempting to associate that certain VM as opposed to trying all the VMs

Expected results:
The VM should have been associated at step 3

Additional info:
In /usr/share/foreman/app/services/compute_resource_host_associator.rb , line 13, compute_resource.vms(:eager_loading => true) returns []

Associated revisions

Revision b6406cd7 (diff)
Added by Ori Rabin 4 months ago

Fixes #24564, #24746 - bump version of fog-ovirt

Now clusters shown for ovirt are only those in the datacenter.
Associate VMs for API v4 was fixed by changing filter to only add
pagination when needed.

History

#1 Updated by Ori Rabin 4 months ago

  • Assignee set to Ori Rabin
  • Status changed from New to Assigned

#2 Updated by Ori Rabin 4 months ago

Fix open for fog-ovirt (https://github.com/fog/fog-ovirt/pull/36). Keeping bug open here because this needs a dependency bump of fog-ovirt once fix is in.

#3 Updated by The Foreman Bot 4 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6015 added

#4 Updated by Ori Rabin 4 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Michael Moll 4 months ago

  • Fixed in Releases 1.20.0 added

Also available in: Atom PDF