Project

General

Profile

Bug #24750

hammer host create error: Found more than one compute_resource

Added by Anthony Chevalet almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Hammer
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Red Hat JIRA:

Description

$ hammer host create --compute-resource <resource-name> --compute-profile <profile-name> ...

Error: Found more than one compute_resource. / compute_profile.

Since hammer 0.12.0 (Foreman 1.17) passing names doesn't work. We have to use IDs instead.
The exact same command works with hammer 0.11.0.
Tested on Foreman 1.18.1 and 1.19RC3 with Katello plugin.

As hammer doesn't support compute profiles yet, it becomes hardly usable for hosts provisioning (without direct API call)


Related issues

Related to Katello - Refactor #26027: hammer_cli_katello resolvers interfere with foreman onces on katello-extended resourcesNew

Associated revisions

Revision b580073e (diff)
Added by Martin Bacovsky over 3 years ago

Fixes #24750 - Search options for compute profiles (#619)

Keep foreman API compatible search options for compute profiles.

History

#1 Updated by Alex .. almost 4 years ago

  • Found in Releases 1.18.1 added

I have also found in 1.18.0 and 1.18.1. Not only `compute-resource` fails but also `compute-profile` forcing to use `-id`

#2 Updated by Martin Bacovsky over 3 years ago

  • Bugzilla link set to 1665780
  • Triaged changed from No to Yes
  • Assignee set to Martin Bacovsky
  • Status changed from New to Assigned
  • Category changed from Host creation to Hammer
  • Project changed from Foreman to Katello

The cause is that building of the search arguments is unintentionally modified by Katello plugin for hammer. Compute profiles needs to be added to foreman_search_options_creators.rb

#3 Updated by The Foreman Bot over 3 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/619 added

#4 Updated by Martin Bacovsky over 3 years ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Ivan Necas over 3 years ago

  • Related to Refactor #26027: hammer_cli_katello resolvers interfere with foreman onces on katello-extended resources added

Also available in: Atom PDF