Project

General

Profile

Bug #24757

audits - type: user not recognized for searching

Added by Tomer Brisker over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1619732

Description of problem:
this used to work in 6.3:

one is unable to search the audits by a type: user.

Received HTTP 400 response: {
"error": {"message":"'auditable_type' should be one of 'role, ptable, provisioning_template, filter, hostgroup, katello/repository, smart_proxy, katello/host/content_facet, katello/host/subscription_facet, remote_execution_feature, lookup_value, model, domain, realm, environment, architecture, image, usergroup, job_template, bookmark, hostgroup_class, puppetclass, medium, job_invocation, ansible_role, discovery_rule, katello/activation_key, katello/content_view, katello/kt_environment, katello/host_collection, katello/sync_plan, katello/capsule_lifecycle_environment, katello/content_view_component, katello/content_view_environment, katello/content_view_puppet_module, katello/content_view_version, katello/gpg_key, katello/product, foreman_virt_who_configure/config, foreman_openscap/policy, foreman_openscap/scap_content, foreman_openscap/tailoring_file, compute_profile, config_group, config_group_class, ssh_key, compute_attribute, host_class, host_config_group, http_proxy, key_pair, personal_access_token, auth_source, compute_resource, host, interface, location, organization, os, override_value, parameter, partition_table, setting, smart_class_parameter, smart_variable, subnet', but the query was 'user'","class":"ScopedSearch::QueryNotSupported"}

Version-Release number of selected component (if applicable):
6.4.0-19

Associated revisions

Revision 458c5a51 (diff)
Added by Marek Hulán over 1 year ago

Fixes #24757 - fix audit searching by user

History

#1 Updated by Tomer Brisker over 1 year ago

  • Category deleted (Audit Log)
  • Project changed from Foreman to Katello

This is caused by CpConsumerUser inheriting from the User class in foreman, making the audit search skip it (since auditing STI classes has issues)

#2 Updated by Justin Sherrill over 1 year ago

  • Target version set to Katello 3.9.0

#3 Updated by The Foreman Bot over 1 year ago

  • Assignee set to Marek Hulán
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7685 added

#4 Updated by Marek Hulán over 1 year ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Jonathon Turel over 1 year ago

  • Triaged changed from No to Yes

Also available in: Atom PDF