Project

General

Profile

Bug #24810

Missing value in product details causes values to not align to their labels

Added by Andrew Kofink over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1625175

On Subscription details page, there are 4 values displayed for each product: Content Download URL, GPG Key URL, Repo Type and Enabled?. If one value is missing, it causes subsequent values to shift up and not align with their labels. See attached screenshot.

Version-Release number of selected component (if applicable):
tfm-rubygem-katello-3.7.0

Steps to Reproduce:
1. Create new product. Make sure that GPG Key field remains empty. Add one yum repository: https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/
2. Content -> Subscriptions -> Product from previous step -> Enabled Products -> expand product
3. Try to read data

Solution:
The root cause is HTML structure displaying ultimately tabular data in column-oriented way instead of row-oriented way.

Instead of (simplified code):

<div class="col-sm-3">
<div class="row">Label</div>
</div>
<div class="col-sm-9">
<div class="row">value</div>
</div>

It should be:

<div class="row">
<div class="col-sm-3">
Label
</div>
<div class="col-sm-9">
value
</div>
</div>

New structure would also make data more readable on phones / very narrow screens. Right now it's all labels, all values, one under another. With new structure, it would be label, value, intertwined.

Associated revisions

Revision 75e26d47 (diff)
Added by Amir Fefer over 1 year ago

Fixes #24810 - allign text in subscriptions details page

History

#1 Updated by Tomáš Strachota over 1 year ago

  • Subject changed from Missing value in product details causes values to not align to their labels to Missing value in product details causes values to not align to their labels
  • Team Backlog UX added

#2 Updated by Justin Sherrill over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.9.0

#3 Updated by The Foreman Bot over 1 year ago

  • Assignee set to Amir Fefer
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7680 added

#4 Updated by Amir Fefer over 1 year ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF