Project

General

Profile

Bug #24839

Subscriptions tab links to /legacy_subscriptions/:id:

Added by Samir Jha over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Activation Key
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1625215

In Activation Key details page, Subscriptions tab, link in "Attached" column points to /legacy_subscriptions/:id: instead of /subscriptions/:id:

Version-Release number of selected component (if applicable):
Satellite 6.4.0 snap 20
tfm-rubygem-katello-3.7.0.22-1.el7sat.noarch

Steps to Reproduce:
1. Create product (or upload manifest and enable Red Hat products)
2. Content -> Activation keys -> Create activation key -> fill in form -> Save
3. Subscriptions tab -> Add
4. Click any link in "Attached" column

Additional info:
Since Bug 1603239 has been resolved, new Subscriptions pages contain all the same information as old Subscription pages (still available under /legacy_subscriptions), so it probably does make sense to link to new pages instead.

Associated revisions

Revision 40570524 (diff)
Added by sjha4 over 1 year ago

Fixes #24839 - Legacy Subscriptions tab links

History

#1 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7683 added

#2 Updated by Anonymous over 1 year ago

  • Status changed from Ready For Testing to Closed

#3 Updated by Jonathon Turel over 1 year ago

  • Target version set to 931

#4 Updated by Jonathon Turel over 1 year ago

  • Triaged changed from No to Yes

#5 Updated by Jonathon Turel over 1 year ago

  • Target version changed from 931 to Katello 3.9.0

Also available in: Atom PDF