Project

General

Profile

Bug #2486

Fact values importer recreating all values in the database

Added by Dominic Cleal about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Facts
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When uploading facts via /fact_values/create, a large number of database inserts are made as it's deleting all existing associated fact_values and inserting new ones. By design it should only be deleting changed values, then inserting the new ones.


Related issues

Related to Foreman - Bug #2301: Nodes with puppet running are not always listed in REST responsesResolved2013-03-11

Associated revisions

Revision 6dffd64b (diff)
Added by Dominic Cleal about 6 years ago

fixes #2486 - ensure facts import is idempotent when values are unchanged

Revision 824b150d (diff)
Added by Dominic Cleal about 6 years ago

fixes #2486 - ensure facts import is idempotent when values are unchanged
(cherry picked from commit 6dffd64b9d1e0be4cdf76534877438f52c42f200)

History

#1 Updated by Dominic Cleal about 6 years ago

  • Status changed from Assigned to Ready For Testing

https://github.com/theforeman/foreman/pull/604

I hope this will have a nice performance boost too.

#2 Updated by Dominic Cleal about 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF