Project

General

Profile

Bug #24870

When Setting has a "empty" default, the tool tip shows an empty string.

Added by Marek Hulán 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Settings
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1626138

Description of problem: If a setting's default value is "None", not set, empty, etc. The tool tip Shows an empty string.

For example:

General-> Login page footer text tooltip says " Login page footer text (Default: )"

We might want to be a little more explicit.

Also, in the values column it typically says "Empty" when the setting is not set. Perhaps we should consider changing this, and the tool tip when this is the default, to something like "Not Set" to be more explicit.

See attached example screen shot

Version-Release number of selected component (if applicable): 6.4.0 snap 20

How reproducible: Always


Related issues

Related to Foreman - Feature #24835: Non-default settings should be bolded.Closed

Associated revisions

Revision cbfa3f4b (diff)
Added by boaz shust 2 months ago

Fixes #24870 - show a setting does not have a default value (#6089)

Signed-off-by: Boaz Shuster <>

History

#1 Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6089 added

#2 Updated by Lukas Zapletal 2 months ago

  • Related to Feature #24835: Non-default settings should be bolded. added

#3 Updated by Lukas Zapletal 2 months ago

  • Subject changed from When Setting has a "empty" default, the tool tip shows an empty string. to When Setting has a "empty" default, the tool tip shows an empty string.
  • Fixed in Releases 1.20.0 added

#4 Updated by boaz shust 2 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF