Project

General

Profile

Bug #24931

@dynamic kickstart variable stopped working in Foreman 1.19.0

Added by Guilherme M. Schroeder over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Templates
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hi,

We use the @dynamic variable in Foreman kickstart templates and it seems it stopped working with the 1.19.0 release. It works fine in 1.18.2.
The partition table associated with the host starts with #Dynamic.


Related issues

Related to Foreman - Bug #21172: Unknown Variables in partition tables <%= @osver %>Closed2017-10-02
Is duplicate of Foreman - Bug #25150: regression: @dynamic in template is always falseClosed

History

#1 Updated by Tomer Brisker over 1 year ago

  • Related to Bug #21172: Unknown Variables in partition tables <%= @osver %> added

#2 Updated by Tomer Brisker over 1 year ago

  • Target version set to 1.19.1
  • Category set to Templates
  • Found in Releases 1.19.0 added

#3 Updated by Ivan Necas over 1 year ago

At Tomer noted, this might be related to this change https://github.com/theforeman/foreman/commit/1f32612a032977b05c27042422d050c9638dc3a6, I will investigate next week to confirm this and hopefully find a fix.

#4 Updated by Olmo Rupert over 1 year ago

Issue confirmed. It broke our provisioning capabilities.

Two kickstart templates provided.

1. old working one ( via 1.16 ... ): https://pastebin.com/YWV5bxUq
2. broken one ( via 1.19 .. ): https://pastebin.com/BWguxkbk

#5 Updated by Ivan Necas over 1 year ago

  • Status changed from New to Duplicate

#6 Updated by Ivan Necas over 1 year ago

  • Is duplicate of Bug #25150: regression: @dynamic in template is always false added

#7 Updated by Olmo Rupert over 1 year ago

Able to temporarily bypass the issue by specifying the partition table explicitly in the wizard.

Also available in: Atom PDF