Project

General

Profile

Bug #25024

Failed to fetch a free IP from proxy - undefined local variable or method `opts' for ms dhcp server:Proxy::DHCP::NativeMS::Provider

Added by Jeff Sparrow 3 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
DHCP
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I just upgraded from 1.15 to 1.19 proxies. I wanted to wait for the MS DHCP API changes to bake in.
Now I am hitting the following error on IP request, which previously worked without issues.

Failed to fetch a free IP from proxy foreman-dhcp-lab3-4 (https://foreman-deploy.lab.beer.town:8448): ERF12-8202 [ProxyAPI::ProxyException]: Unable to retrieve unused IP ([RestClient::BadRequest]: 400 Bad Request) for proxy https://foreman-deploy.lab.beer.town:8448/dhcp

https://gist.github.com/tek0011/432722c057ad0c947414fa8316c3230a


Related issues

Related to Smart Proxy - Bug #24591: Incorrect error reporting for MS DHCPClosed

History

#1 Updated by Jeff Sparrow 3 months ago

It appears the issue is only related to finding a new IP.
I am able to manually give it an IP and provision it. Obviously this isnt ideal, as I have to manually search for an IP each time.

#2 Updated by Jeff Sparrow 3 months ago

Seeing this error while looking at the servers processes during a request. Any idea if this means anything?

#3 Updated by Jeff Sparrow 3 months ago

I created the folder and now it looks like it wants to create another folder thats missing. Something seems quite wrong here.

#4 Updated by Lukas Zapletal 3 months ago

  • Priority changed from High to Normal
  • Status changed from New to Duplicate

Dupe of #24591 fixed upstream. One line patch, apply it onto your instance.

#5 Updated by Lukas Zapletal 3 months ago

  • Related to Bug #24591: Incorrect error reporting for MS DHCP added

#6 Updated by Lukas Zapletal 3 months ago

  • Fixed in Releases 1.20.0 added

#7 Updated by Jeff Sparrow 3 months ago

Lukas Zapletal wrote:

Dupe of #24591 fixed upstream. One line patch, apply it onto your instance.

Thanks Lukas. Worked.

Also available in: Atom PDF