Project

General

Profile

Bug #25034

Repositories drop downs show duplicate named repositories

Added by Andrew Kofink over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Lifecycle Environments
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Reproduce:

1. Publish a repository in a content view
2. Content -> Lifecycle Environments -> Click a LE -> Packages tab

Actual
The repositories dropdown contains repos with the same name from different Content Views

Expected
The repositories dropdown contains no duplicate named repos - selecting 'zoo' should show all zoo repos across all content views. The content view dropdown should be sufficient to filter by content view and repository.

Associated revisions

Revision 9ee1692f (diff)
Added by Partha Aji about 3 years ago

Fixes #25034 - No Duplicate repos on LCE UI (#7969)

  • Fixes #25034 - No Duplicate repos on LCE UI

Click on a Lifecycle Env Details page. Notice that there is a "All
Content View" selction option and duplicate repository names displayed
in the "repositories" section. The duplication is because the same
repository is in multiple content views.
This commmit tries to address this issue by removing the "All Content
Views" option which is probably never used. Instead it auto selects the
first available content view and displays repositories belonging to
that.

  • Refs #25034 - UI Changes from PR

1) Added a "Select Content View" instead of "All Content Views"
2) By default no repos, errata or packages loaded unless you chose a cv

History

#1 Updated by John Mitsch over 3 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.9.1

#2 Updated by Andrew Kofink over 3 years ago

  • Bugzilla link set to 1633341

#3 Updated by The Foreman Bot over 3 years ago

  • Assignee set to Partha Aji
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7969 added

#4 Updated by Christine Fouant over 3 years ago

  • Target version changed from Katello 3.9.1 to Katello 3.12.0

#5 Updated by Anonymous about 3 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF