Project

General

Profile

Bug #25097

Listing puppet classes fails after adding default organization/location

Added by Marek Hulán 8 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Category:
Organizations and Locations
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1631379

Description of problem: After adding default organization/location, Listing puppet class fails with error

Internal Server Error: the server was unable to finish the request. This may be caused by unavailability of some required service, incorrect API call or a server-side bug. There may be more information in the server's logs.

Version-Release number of selected component (if applicable): Satellite 6.4
satellite-6.4.0-14.el7sat.noarch

How reproducible: Always

Steps to Reproduce:

[root@satellite64 ~]# hammer organization list
---|----------------------|----------------------|-------------|----------------------
ID | TITLE | NAME | DESCRIPTION | LABEL
---|----------------------|----------------------|-------------|----------------------
1 | Default Organization | Default Organization | | Default_Organization
---|----------------------|----------------------|-------------|----------------------

[root@satellite64 ~]# hammer defaults list
----------------|------
PARAMETER | VALUE
----------------|------
organization_id | 1
----------------|------

[root@satellite64 ~]# hammer puppet-class list
Internal Server Error: the server was unable to finish the request. This may be caused by unavailability of some required service, incorrect API call or a server-side bug. There may be more information in the server's logs*Actual results:*

Expected results: It should list puppet classes

Additional info: Applied the PR https://github.com/theforeman/foreman/pull/6075/files but still, this is failing.
This is working in satellite 6.3


Related issues

Related to Foreman - Bug #26405: Puppetclass index implicitly searches locations and organizationsClosed

Associated revisions

Revision 4cf21db0 (diff)
Added by Sebastian Gräßl 6 months ago

Fixes #25097,#25277 - Associate reports & classes with taxonomy

History

#1 Updated by The Foreman Bot 8 months ago

  • Pull request https://github.com/theforeman/foreman/pull/6106 added

#2 Updated by The Foreman Bot 8 months ago

  • Status changed from New to Ready For Testing

#3 Updated by The Foreman Bot 6 months ago

  • Pull request https://github.com/theforeman/foreman/pull/6306 added

#4 Updated by Tomer Brisker 6 months ago

  • Subject changed from Listing puppet classes fails after adding default organization/location to Listing puppet classes fails after adding default organization/location
  • Fixed in Releases 1.21.0 added

#5 Updated by Tomer Brisker 6 months ago

  • Pull request deleted (https://github.com/theforeman/foreman/pull/6106)

#6 Updated by Sebastian Gräßl 6 months ago

  • Status changed from Ready For Testing to Closed

#7 Updated by Tomer Brisker 2 months ago

  • Related to Bug #26405: Puppetclass index implicitly searches locations and organizations added

Also available in: Atom PDF