Project

General

Profile

Bug #25113

Subscriptions details page does not handle Org switch correctly.

Added by Walden Raines about 1 year ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1635305

Description of problem:
I found this while verifying bz 1609817, It seems to be similar to that bug but happens when you select a specific subscription to view details, then try to switch the org.

Version-Release number of selected component (if applicable): 6.4 snap 25

How reproducible: Always

Steps to Reproduce:

--Flow 1--
1. Start with default org.
2. On subscriptions page select one of the subscription
3. Using the mast head org switcher, change to another org with different subscriptions.

Actual Results:
The details for the subscription still show. Clicking the enabled products tab shows it as empty.

See Screen recording here:
https://drive.google.com/open?id=1fdDT-LsEwNRioPON6eHaHICpz8kiFYOl

Expected results
User is directed to the main subscriptions page for the selected org.

--Flow 2--
1. Start with default org
2. On subscriptions page select one of the subscriptions
3. Using mast head org switcher, select "Any Organization"

Actual Results:

2 errors are displayed with message "Organization with id undefined not found"

See screen recording here:
https://drive.google.com/open?id=1baKSgSWnx6w-vZWQrU-or9v8ZCCyt3i5

Expected Results:
User is directed to org selection page.

Additional info:
I added the screen recordings to this folder, if you find additional examples please add upload them to this folder.
https://drive.google.com/drive/folders/1YnL3EJrZbVSePKTJ7ciBMojjxfpvWA9Z?usp=sharing


Related issues

Related to Katello - Feature #27450: Check a user's permission before allowing them to access react pages Closed
Related to Foreman - Refactor #27451: Rewrite the organization switcher in react/reduxNew

Associated revisions

Revision f4786fa7 (diff)
Added by Jeremy Lenz 3 months ago

Fixes #25113: ensure subscription pages have org

Subscription pages that require an organization to be selected weren't
working properly when 'Any Organization' was selected in the top
toolbar.

  • Use WithOrganization HOC to ensure org is selected when required
  • Enclose the submit button in <a> tag (removes the need for
    redirectPath because redirects are handled by the 302 response returned
    to the browser)
  • Update test & snapshot

https://projects.theforeman.org/issues/25113

History

#1 Updated by Jonathon Turel about 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.10.0

#2 Updated by The Foreman Bot 12 months ago

  • Assignee set to Amir Fefer
  • Pull request https://github.com/Katello/katello/pull/7800 added

#3 Updated by Christine Fouant 11 months ago

  • Target version changed from Katello 3.10.0 to Katello 3.11.0

#4 Updated by Jonathon Turel 9 months ago

  • Target version changed from Katello 3.11.0 to Katello 3.12.0

#5 Updated by Walden Raines 7 months ago

  • Assignee changed from Amir Fefer to Walden Raines
  • Pull request deleted (https://github.com/Katello/katello/pull/7800)

#6 Updated by Walden Raines 7 months ago

  • Status changed from New to Assigned

#7 Updated by The Foreman Bot 7 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8022 added

#8 Updated by The Foreman Bot 7 months ago

  • Pull request https://github.com/Katello/katello/pull/8052 added

#9 Updated by Walden Raines 7 months ago

  • Assignee changed from Walden Raines to John Mitsch
  • Pull request deleted (https://github.com/Katello/katello/pull/8022)

#10 Updated by Jonathon Turel 5 months ago

  • Target version changed from Katello 3.12.0 to Katello 3.12.1

#11 Updated by Samir Jha 4 months ago

  • Target version changed from Katello 3.12.1 to Katello 3.13.0

#12 Updated by Walden Raines 4 months ago

  • Assignee changed from John Mitsch to Walden Raines

#13 Updated by Walden Raines 3 months ago

  • Assignee changed from Walden Raines to Jeremy Lenz

#14 Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/Katello/katello/pull/8227 added

#15 Updated by Walden Raines 3 months ago

  • Related to Feature #27450: Check a user's permission before allowing them to access react pages added

#16 Updated by Walden Raines 3 months ago

  • Related to Refactor #27451: Rewrite the organization switcher in react/redux added

#17 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases Katello 3.14.0 added

#18 Updated by Jeremy Lenz 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF