Project

General

Profile

Actions

Bug #25134

closed

HTML is shown in alert box

Added by Gilad Lekner over 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

Steps to reproduce:

  1. Go to Provisioning Templates
  2. Clone a Template
  3. Click on Preview

See Screenshot:


Files


Related issues 1 (0 open1 closed)

Is duplicate of Foreman - Bug #22898: Preview fails on /clone_template - 404 returnedClosedAditi PuntambekarActions
Actions #1

Updated by Marek Hulán over 5 years ago

Could you please share the whole trace? The problem is not that we display HTML tags, but the content we put into that alert. This is 500 response, which seems to be specific to your env. It says unsupportes browser, so I wonder what do you use :-)

Actions #2

Updated by Ohad Levy over 5 years ago

if you actually look, you would see its a full page response, including the warning about the browser (which exists in every page foreman providers).
the actual error is provision template not found

Actions #3

Updated by Marek Hulán over 5 years ago

Ah, sorry I read just part of that HTML (on phone). I can't reproduce on develop though, does that happen for all templates you have? Could you upload the log from the server with debug log level? Thanks

Actions #4

Updated by Tomer Brisker about 5 years ago

  • Status changed from New to Duplicate

Seems to be duplicate of #22898

Actions #5

Updated by Tomer Brisker about 5 years ago

  • Is duplicate of Bug #22898: Preview fails on /clone_template - 404 returned added
Actions

Also available in: Atom PDF