Project

General

Profile

Bug #2519

Admin account not enabled after db:migrate

Added by Greg Sutcliffe about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Urgent
Category:
Authentication
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

twice today i've installed new foreman hosts (once from git, once from debian nightly) and the standard admin:changeme did not work. Both were postgres. Both worked after permissions:reset.

Associated revisions

Revision a2a5a5fe (diff)
Added by Greg Sutcliffe about 6 years ago

Fixes #2519 - Protect locale changes from validation failure so that
password validation can be run

Revision cd90e05b (diff)
Added by Greg Sutcliffe about 6 years ago

Fixes #2519 - Protect locale changes from validation failure so that
password validation can be run
(cherry picked from commit a2a5a5fef2950c0a60c5aec3378277e2c5cb47bd)

History

#1 Updated by Dominic Cleal about 6 years ago

  • Category set to Authentication
  • Priority changed from Normal to Urgent

I can replicate this, deleting my sqlite DB, running db:migrate and am unable to login. Checking the database, the password_hash and password_salt fields are empty. Setting them manually to known values allows logins.

#2 Updated by Greg Sutcliffe about 6 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Greg Sutcliffe

#3 Updated by Greg Sutcliffe about 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF