Project

General

Profile

Bug #25198

SearchBar results keyboard arrows navigation doesn't work properly

Added by Ron Lavi 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Seems that the keyboard navigation doesn't work as expected:
- instead of first down-arrow click, the first list item is being selected only after two clicks.
- can't reach the last list element.


Related issues

Related to Foreman - Feature #24040: Move the search box in Hardware Models to a React componentClosed
Is duplicate of Foreman - Bug #25189: New searching functionality does not allow arrow keys navigationResolved

Associated revisions

Revision 3707a3c8 (diff)
Added by Ron Lavi 2 months ago

fixes #25198 - Fix SearchBar keyboard navigation.

History

#1 Updated by The Foreman Bot 2 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6139 added

#2 Updated by Tomer Brisker 2 months ago

  • Fixed in Releases 1.20.0 added

#3 Updated by Tomer Brisker 2 months ago

  • Assignee set to Ron Lavi
  • Category set to Web Interface

#4 Updated by Tomer Brisker 2 months ago

  • Related to Feature #24040: Move the search box in Hardware Models to a React component added

#5 Updated by Ron Lavi 2 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Ron Lavi 2 months ago

  • Is duplicate of Bug #25189: New searching functionality does not allow arrow keys navigation added

Also available in: Atom PDF