Project

General

Profile

Bug #25225

Preallocate disk checkbox is broken for additional disks of a template

Added by Ivan Necas 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - oVirt
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1637955

Description of problem:
When Satellite creates a VM based on RHV template with additional disks with 'preallocated disk' checked, the VM creation fails with HTTP 404 error.

How reproducible:
100%

Steps to Reproduce:
1. Create a template on RHV with no disks
2. Provision a VM based on this template from the Satellite with one disk with preallocated disk checked to true

Actual results:
HTTP 404

Expected results:
VM is created

Additional info:
The issue is caused by the following or similar call:
https://RHV-M-FQDN/ovirt-engine/api/v3/vms

data:

<vm>
<name>TestVM</name>
<description/>
<template id="e3636a0e-68af-4478-a197-cb5da8e28f32"/>
<quota id="5bb76c0e-025d-004e-0343-00000000012d"/>
<cluster id="5bb76bf3-0189-0293-03a4-000000000392"/>
<type>Server</type>
<memory>4294967296</memory>
<cpu>
<topology cores="2" sockets="1"/>
</cpu>
<disks>
<clone>true</clone>
<disk id="">
<storage_domains>
<storage_domain id="84485ec1-873f-402b-83a9-ba9c2a0d83cb"/>
</storage_domains>
<format>raw</format>
<sparse>false</sparse>
</disk>
</disks>
</vm>

Associated revisions

Revision 6509048b (diff)
Added by Ivan Necas about 2 months ago

Fixes #25225 - clone oVirt disk only when source disk exists

History

#1 Updated by The Foreman Bot 2 months ago

  • Assignee set to Ivan Necas
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6152 added

#2 Updated by Ivan Necas about 2 months ago

  • Status changed from Ready For Testing to Closed

#3 Updated by Tomer Brisker about 2 months ago

  • Subject changed from Preallocate disk checkbox is broken for additional disks of a template to Preallocate disk checkbox is broken for additional disks of a template
  • Fixed in Releases 1.20.0 added

Also available in: Atom PDF