Project

General

Profile

Bug #25231

"the field 'created_at' in the order statement is not valid field for search" on content view history tab

Added by Mirosław Zalewski 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Navigating to content view History tab results in empty table and error notification: the field 'created_at' in the order statement is not valid field for search.
Root cause is API call to /katello/api/v2/content_views/4/history?organization_id=1&page=NaN&paged=true&per_page=20&search=&sort_by=created_at&sort_order=DESC

Katello git commit id: 77a4d76db2d1524f152281a78ef8d17f4fdfa646
Foreman git commit id: 9ccfbde5c417ed466b21c997d01d4608cc4e8c57

Steps to reproduce:
1. Create new content view
2. Open this content view and navigate to History tab

Expected results:
There is no error notification; history data is displayed in table (if there is any history to display).


Related issues

Related to Katello - Bug #25232: CV History: Incorrect API call due to parsing error (page=NaN)Resolved

Associated revisions

Revision 5aedfccc (diff)
Added by Christine Fouant 6 months ago

fixes #25231 - fixes default order field in content view history

History

#1 Updated by Mirosław Zalewski 6 months ago

  • Found in Releases Nightly added

#2 Updated by Mirosław Zalewski 6 months ago

  • Related to Bug #25232: CV History: Incorrect API call due to parsing error (page=NaN) added

#3 Updated by Tomer Brisker 6 months ago

  • Category changed from API to API
  • Project changed from Foreman to Katello

#4 Updated by John Mitsch 6 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.9.0
  • Assignee set to Christine Fouant
  • Category changed from API to Content Views

#5 Updated by Jonathon Turel 6 months ago

  • Target version changed from Katello 3.9.0 to Katello 3.10.0

#6 Updated by The Foreman Bot 6 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7804 added

#7 Updated by Christine Fouant 6 months ago

  • Status changed from Ready For Testing to Closed

#8 Updated by Brad Buckingham 5 months ago

  • Bugzilla link set to 1646184

Also available in: Atom PDF