Project

General

Profile

Feature #25345

As a user I would like to see Upgradable Module Streams for a Content Host

Added by Partha Aji almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Modularity
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Related to -> https://pulp.plan.io/issues/3925

Pulp plans to provide the ability calculate applicability on errata with Module Streams. Katello needs to be able to show information on module streams that are updatable. This task consists of the following steps

1) Make sure pulp gets passed the module streams information provided by subscription manager
2) Create models for applicable modules streams (similar to what we have for rpms and errata)
3) Add the model code to calculate applicability wherever errata / packages are done
4) Add information to the available module streams json to show packages that are upgradable
5) Add information in the UI to indicate modules as upgradable.


Related issues

Related to Katello - Tracker #24400: Modularity - P1Closed

Associated revisions

Revision b378a5cd (diff)
Added by Partha Aji almost 2 years ago

Fixes #25345 - Modulestream Applicability bindings (#7844)

  • Fixes #25345 - Modulestream Applicability bindings

This commit adds bindings for applicable and upgradable module streams.
Includes UI Changes

History

#1 Updated by Partha Aji almost 2 years ago

#2 Updated by Jonathon Turel almost 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.10.0

#3 Updated by The Foreman Bot almost 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7844 added

#4 Updated by Anonymous almost 2 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF