Project

General

Profile

Bug #25360

intermittent failing test in activation_key_test.rb and debvcr

Added by Chris Duryee 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Tests
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

There is a test in actviation_key_test.rb that fails sometimes, depending on the ordering of an array.

There is another test in the Debian repo create that fails as well. Both need to be addressed.

Associated revisions

Revision cee70cb9 (diff)
Added by Chris Duryee 7 months ago

Fixes #25360 - two test fixups

1.) do not compare ordering of array in activation key test

2.) remove debian vcr test that intermittently fails. We do not have a
root cause for this yet. We are removing the test to confirm
that the failure does not move to another test when this one is
removed.

History

#1 Updated by The Foreman Bot 7 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7801 added

#2 Updated by Chris Duryee 7 months ago

  • Description updated (diff)
  • Subject changed from intermittent failing test in activation_key_test.rb to intermittent failing test in activation_key_test.rb and debvcr

#3 Updated by Chris Duryee 7 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Justin Sherrill 7 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.10.0
  • Category changed from Activation Key to Tests

Also available in: Atom PDF