Project

General

Profile

Bug #25392

Test failure ActiveRecord::RecordNotFound: Couldn't find SmartProxy without an ID

Added by Justin Sherrill 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Category:
Tests
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Error:
Actions::Pulp::Repository::RefreshTest::Refresh#test_0001_runs:
ActiveRecord::RecordNotFound: Couldn't find SmartProxy without an ID
/home/vagrant/git/katello/app/lib/actions/pulp/abstract.rb:16:in `smart_proxy'
/home/vagrant/git/katello/app/lib/actions/pulp/repository/refresh.rb:16:in `run'
/home/vagrant/git/katello/app/lib/actions/middleware/remote_action.rb:16:in `block in run'
/home/vagrant/git/katello/app/lib/actions/middleware/remote_action.rb:40:in `block in as_remote_user'
/home/vagrant/git/katello/app/models/katello/concerns/user_extensions.rb:21:in `cp_config'
/home/vagrant/git/katello/app/lib/actions/middleware/remote_action.rb:27:in `as_cp_user'
/home/vagrant/git/katello/app/lib/actions/middleware/remote_action.rb:39:in `as_remote_user'
/home/vagrant/git/katello/app/lib/actions/middleware/remote_action.rb:16:in `run'
/home/vagrant/git/foreman-tasks/app/lib/actions/middleware/rails_executor_wrap.rb:14:in `block in run'
/home/vagrant/git/foreman-tasks/app/lib/actions/middleware/rails_executor_wrap.rb:13:in `run'
/home/vagrant/git/katello/test/actions/pulp/repository/refresh_test.rb:32:in `block (2 levels) in <class:RefreshTest>'


Related issues

Related to Katello - Bug #25371: Capsule syncs failClosed

Associated revisions

Revision b320ee90 (diff)
Added by Justin Sherrill 7 months ago

Fixes #25392 - refresh action test fix

caused by two colliding commits

History

#1 Updated by The Foreman Bot 7 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7812 added

#2 Updated by Justin Sherrill 7 months ago

  • Status changed from Ready For Testing to Closed

#3 Updated by Justin Sherrill 7 months ago

#4 Updated by Justin Sherrill 7 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.10.0

Also available in: Atom PDF