Project

General

Profile

Bug #25418

HTML entities visible on task details page

Added by Mirosław Zalewski 10 months ago. Updated 6 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

HTML entities are visible on task details page of Foreman web UI. See screenshot task_details.png.
Entities are NOT visible on tasks list page (screenshot tasks_list.png).

Observed in version:
foreman-tasks 0.14.2
foreman-tasks-core 0.2.5

NOT observed in version:
tfm-rubygem-foreman-tasks-0.14.1-1.el7sat.noarch
tfm-rubygem-foreman-tasks-core-0.2.5-2.el7sat.noarch

Steps to reproduce:
1. Create some task with HTML special character in name (e.g. < > " ' &) (promoting CV or synchronizing repo should get you started)
2. in Foreman web UI: Monitor -> Tasks -> click task created before
3. Look at task name in breadcrumb navigation

task_details.png View task_details.png 78.6 KB Mirosław Zalewski, 11/08/2018 01:50 PM
tasks_list.png View tasks_list.png 160 KB Mirosław Zalewski, 11/08/2018 01:50 PM
Task details Tasks list

Related issues

Is duplicate of foreman-tasks - Bug #26014: Html numeric code is displayed on task pageClosed

History

#1 Updated by Mirosław Zalewski 6 months ago

  • Related to Bug #26014: Html numeric code is displayed on task page added

#2 Updated by Mirosław Zalewski 6 months ago

  • Related to deleted (Bug #26014: Html numeric code is displayed on task page)

#3 Updated by Mirosław Zalewski 6 months ago

  • Is duplicate of Bug #26014: Html numeric code is displayed on task page added

#4 Updated by Mirosław Zalewski 6 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF