Project

General

Profile

Bug #2545

EC2 instance does not show EC2 related options in Edit page.

Added by Kamil Winczek about 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

EC2 type of instance, while edited, under Operating System tab provides Media, Partition Table, Custom Disk Layout and Root Password instead of just an Architecture, Operating system and Image.

This causes problem with saving edited instance. Foreman says that Image is not selected and won't save the instance. Selecting any Partition Table from the list allows instance to be saved.


Related issues

Related to Foreman - Bug #2551: new host image not always visible under openstackClosed2013-05-23

Associated revisions

Revision 7164f367 (diff)
Added by Ohad Levy almost 6 years ago

fixes #2545 - EC2 instance does not show EC2 related options in Edit page.

Revision 2f2c5ea3 (diff)
Added by Ohad Levy almost 6 years ago

fixes #2545 - EC2 instance does not show EC2 related options in Edit page.
(cherry picked from commit 7164f367646dcd30b53f53d0865788ce15c3666d)

History

#1 Updated by Ohad Levy about 6 years ago

  • Target version set to 1.2.0

#2 Updated by Joseph Magen almost 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Joseph Magen

#3 Updated by Ohad Levy almost 6 years ago

Any chance you can try to reproduce this with 1.2 RC2? I think we've fixed it already.

#4 Updated by Kamil Winczek almost 6 years ago

Issue still occurs with 2e1e6f713d49ef6f5274d798f8882faa2579f680 and https://github.com/witlessbird/foreman/commit/262baf0.patch applied on top of it.

#5 Updated by Joseph Magen almost 6 years ago

Kamil, it looks like your patch was already included in. I assume this issue can be closed. Please confirm.

commit b08d7e45fbdea5f80fad5254e70d8b2004c05e36
Author: Dmitri Dolguikh <>
Date: Fri May 31 10:32:55 2013 +0100

fixes #2588 - fixed regression introduced earlier: localization works for non-AR classes too now

app/helpers/layout_helper.rb

commit 2e1e6f713d49ef6f5274d798f8882faa2579f680
Author: Dmitri Dolguikh <>
Date: Thu May 30 14:48:25 2013 +0100

fixes #2588 - table name used for localization is being determined correctly now for sti classes.

app/helpers/layout_helper.rb

#6 Updated by Joseph Magen almost 6 years ago

I misunderstood. I think you wrote that it still doesn't work after applying the patch. I originally thought that you were sending the .patch as a soluion.

#7 Updated by Ohad Levy almost 6 years ago

  • Category set to Web Interface
  • Assignee changed from Joseph Magen to Ohad Levy

#8 Updated by Ohad Levy almost 6 years ago

  • Status changed from Assigned to Ready For Testing

#9 Updated by Ohad Levy almost 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#10 Updated by Kamil Winczek almost 6 years ago

Working now. Thank you.

#11 Updated by Dominic Cleal almost 6 years ago

Kamil Winczek wrote:

Working now. Thank you.

Thanks for confirming!

Also available in: Atom PDF