Project

General

Profile

Bug #25467

Menu and top bar will disappear periodically on page refresh/change

Added by John Mitsch 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

We will get this behavior along with this error in the console:

VM779 vendor.js:148812 Uncaught TypeError: Cannot read property 'firstname' of undefined
at UserDropdowns (VM785 bundle.js:9758)
at mountIndeterminateComponent (VM779 vendor.js:145201)
at beginWork (VM779 vendor.js:145525)
at performUnitOfWork (VM779 vendor.js:147872)
at workLoop (VM779 vendor.js:147910)
at renderRoot (VM779 vendor.js:147989)
at performWorkOnRoot (VM779 vendor.js:148843)
at performWork (VM779 vendor.js:148751)
at performSyncWork (VM779 vendor.js:148723)
at requestWork (VM779 vendor.js:148611)

where_did_everything_go.png View where_did_everything_go.png 29.7 KB John Mitsch, 11/14/2018 06:41 PM
Where did everything go

Associated revisions

Revision bac064a7 (diff)
Added by John Mitsch 3 months ago

Fixes #25467 - The menu and top bar will disappear periodically

I haven't been able to consistently reproduce this, but myself and
other devs have seen the menu and top bar not reload on page refresh.
It seems to be correlated to an error found in the JS console:
Uncaught TypeError: Cannot read property 'firstname' of undefined

This commit adds a check that user.current_user.user is defined
in addition to the other checks.

History

#1 Updated by John Mitsch 4 months ago

screenshot of issue

#2 Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6246 added

#3 Updated by Tomáš Strachota 3 months ago

  • Fixed in Releases 1.21.0 added

#4 Updated by John Mitsch 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF