Project

General

Profile

Bug #25475

Updating a repo causes Actions::Pulp::Repository::Refresh to fail with Couldn't find SmartProxy without an ID

Added by Andrew Kofink almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Reproduce:

Create a repo
Edit the repo's URL

Actual:
Actions::Pulp::Repository::Refresh fails with "Couldn't find SmartProxy without an ID"

Expected:
No failure


Related issues

Related to Katello - Refactor #24878: Pulp repository service migration: Refresh/updateClosed

Associated revisions

Revision 569c0f3f (diff)
Added by Andrew Kofink almost 2 years ago

Fixes #25475: Use default proxy for nil capsule_id

History

#1 Updated by Andrew Kofink almost 2 years ago

  • Related to Refactor #24878: Pulp repository service migration: Refresh/update added

#2 Updated by Andrew Kofink almost 2 years ago

  • Target version set to Katello 3.10.0

#3 Updated by The Foreman Bot almost 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7838 added

#4 Updated by Andrew Kofink almost 2 years ago

  • Status changed from Ready For Testing to Closed

#5 Updated by John Mitsch almost 2 years ago

  • Triaged changed from No to Yes

#6 Updated by Samir Jha almost 2 years ago

  • Target version changed from Katello 3.10.0 to Katello 3.9.1

Moving this to 3.9.1 as the issue is in 3.9.

#7 Updated by Samir Jha almost 2 years ago

  • Target version changed from Katello 3.9.1 to Katello 3.10.0

Also available in: Atom PDF